Platform Back End Loading Issues

Incident Report for Exercise.com

Resolved

Between 12:16pm and 12:24pm today, Exercise.com experienced a brief period of degraded performance affecting backend services.
During this window, some API calls and data requests may have been delayed or failed to load properly.

The issue has been fully resolved, and performance has returned to normal.

We’re continuing to monitor system health and implement additional safeguards to prevent similar slowdowns in the future.

Thank you for your patience while we worked to restore full functionality.
Posted Oct 16, 2025 - 12:24 EDT

Investigating

We are currently investigating an issue affecting backend performance across all Exercise.com platforms.

Some users may experience slow loading, intermittent errors, or timeouts when accessing pages or features that rely on our API.

Our engineering team is actively investigating and working to restore normal performance as quickly as possible.
We’ll share updates as soon as we have more information.
Posted Oct 16, 2025 - 12:16 EDT
This incident affected: Exercise.com Platform Websites, Mobile Application, and API.