Exercise.com Website Loading Issues - Cloudfare Outage

Incident Report for Exercise.com

Resolved

We are updating this to Resolved based on Cloudflare's latest updates as of 12:44pm EST: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 13:17 EST

Monitoring

We are continuing to monitor the status and updates from Cloudflare: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:02 EST

Identified

We confirmed this issue is related to the ongoing Cloudflare outage.
Posted Nov 18, 2025 - 06:52 EST

Investigating

We are investigating issues with our Exercise.com Website loading related to the ongoing Cloudflare outage.
Posted Nov 18, 2025 - 06:33 EST
This incident affected: Exercise.com Website.