Platform Websites Front End Outage

Incident Report for Exercise.com

Resolved

Between 10:31 AM – 10:36 AM EST, Exercise.com experienced a brief outage that affected access to our platform websites and select pages of our mobile apps.

All services are now fully operational. The outage lasted approximately 4–5 minutes, during which pages and endpoints may have failed to load.

We’ve identified the root cause and implemented mitigation steps to prevent recurrence.

Thank you for your patience while we restored service.
Posted Oct 16, 2025 - 10:36 EDT

Investigating

We are currently investigating an issue causing downtime affecting the front end of all Exercise.com platforms, including the website and select mobile app pages.

Users may be unable to load pages or access their accounts at this time.

Our team is actively working to resolve the issue and will provide updates as soon as we have more information.

Thank you for your patience.
Posted Oct 16, 2025 - 10:31 EDT
This incident affected: Exercise.com Platform Websites, Mobile Application, and API.