We are closing this incident as we have not seen significant loading issues for a prolonged monitoring period.
Posted Sep 12, 2025 - 15:22 EDT
Monitoring
Changes have been implemented, and the Engineering Team is monitoring results.
Posted Sep 12, 2025 - 12:49 EDT
Update
We're experiencing waves of extremely high traffic spikes that are causing intermittent loading issues. Our Engineering Team is working to block the malicious traffic.
Posted Sep 12, 2025 - 11:43 EDT
Identified
We're continuing to see intermittent spikes with unusually long load times.
Posted Sep 12, 2025 - 11:27 EDT
Monitoring
We're seeing significant improvements in load times and reduction of server errors. The Engineering Team will continue to monitor.
Posted Sep 12, 2025 - 10:44 EDT
Investigating
We’re experiencing unusually long load times and are currently investigating.
Posted Sep 12, 2025 - 10:35 EDT
This incident affected: Exercise.com Platform Websites, Mobile Application, Exercise.com Website, and API.