Errors in Customer Checkout Flows

Incident Report for Exercise.com

Resolved

This incident has been resolved
Posted Jul 14, 2024 - 08:38 EDT

Investigating

We are currently investigating this issue.
Posted Jul 14, 2024 - 02:39 EDT
This incident affected: Exercise.com Platform Websites.