Outage at email provider

Incident Report for Exercise.com

Resolved

Our email provider has reported they have restored service
Posted Jan 04, 2023 - 19:18 EST

Identified

Our email provider is currently experiencing an outage. Emails sent from your platform may experience problems with delivery
Posted Jan 04, 2023 - 17:30 EST
This incident affected: Exercise.com Platform Websites.