Performance issues and page timeouts due to Google Cloud Outage

Incident Report for Exercise.com

Resolved

All core services are up and stable. Our Engineering team will continue to monitor.
Posted Jun 12, 2025 - 18:01 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 17:00 EDT

Monitoring

Cloudflare is reporting that their services have been restored and are now fully operational. Google Cloud has confirmed service recovery for most of their products.

Our Engineering Team is continuing to monitor and make sure all systems are back to operating as expected.
Posted Jun 12, 2025 - 16:50 EDT

Identified

Google Cloud is experiencing server issues that are impacting all Exercise.com platform websites and apps. See Google Cloud status page for more: https://status.cloud.google.com/
Posted Jun 12, 2025 - 16:22 EDT

Monitoring

We are starting to see improvements, and will continue to monitor and provide updates.
Posted Jun 12, 2025 - 15:34 EDT

Identified

We are seeing degraded performance with generating reports as part of the ongoing Cloudflare outage. See the Cloudflare status page for more: https://www.cloudflarestatus.com/
Posted Jun 12, 2025 - 14:58 EDT

Investigating

We are currently investigating background jobs being slow to load related to the ongoing Cloudflare outage. See the Cloudflare status page for more: https://www.cloudflarestatus.com/
Posted Jun 12, 2025 - 14:03 EDT
This incident affected: Exercise.com Platform Websites, Mobile Application, Exercise.com Website, and API.