Website loading issues

Incident Report for Exercise.com

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 13:00 EST

Monitoring

We identified potential issues in our upstream hosting provider and are seeing improvements. Our Engineering Team is continuing to monitor performance.
Posted Jan 07, 2026 - 11:28 EST

Investigating

We are currently investigating longer than usual load times on web platforms.
Posted Jan 07, 2026 - 11:04 EST
This incident affected: Exercise.com Platform Websites.