Increased Workout Errors
Incident Report for Exercise.com
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 10:41 EDT
Investigating
We are currently investigating this issue.
Posted Jul 14, 2024 - 14:34 EDT
This incident affected: Mobile Application.