Google Cloud Outage

Incident Report for Exercise.com

Resolved

The server issue incident stemming from issues with our server provider has been resolved as of 8AM EST.
Posted May 02, 2024 - 08:01 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted May 02, 2024 - 07:56 EDT

Identified

The issue with our server provider has been identified with and a fix is being implemented.
Posted May 02, 2024 - 07:32 EDT
This incident affected: Exercise.com Platform Websites, Mobile Application, Exercise.com Website, and API.